SharePoint giving all zeros for correlation id

I had an interesting error come across today when I was working on a new Nintex form list. I have been doing some power user training in my company lately and a few of my users have taken the plunge and started creating their own electronic forms in Nintex.

Which is awesome! It’s a great feeling when you demonstrate something to someone in a training session and then see what they are able to go and create on their own.

In this case, though the user had designed a great looking form, but when they went to submit the form once it was complete it gave the following error:

CorrelationIDAllZeros

Which was very odd as I had never seen an error that gave all zeros for a correlation id on and error in SharePoint.

So I started to do some digging online and I noticed this was a common question that has come up before for several users in the past, but no one online I had seen had dealt with this in the context of creating and submitting forms.

After some more research I had a hunch that this was being caused from a required field on the form that was missing data when the form was being submitted. So I checked the form in Nintex form designer, and sure enough!

I saw that the “Title” column was not on the form, but in the list settings was still set to the required option like it is out of the box in SharePoint.

So I went into the list settings and turned off the required setting for this column and then went back to the form and tried submitting it again.

Everything submitted as it was supposed to and now I can move onto more form troubleshooting.

I hope this helps anyone else who runs into this error again and if you have any thoughts or comments, please feel free to add them into the blog.

 

Thanks! -BJ

Advertisements

Open SharePoint pdf in browser, not in acrobat

So I ran into a frustrating situation lately where my users when they tried to open a pdf in SharePoint, it would launch the pdf in the browser correctly, but at the same time it would open acrobat reader in the foreground with an error message.Screenshot1

This was aggravating, because I could not figure out what setting I needed to modify in order to force acrobat reader to go away without digging deep into acrobat reader.
Well turns out the solution is pretty easy to fix and has to do with an add on in IE.
To correct this issue, go under IE, then manage add ons. Then find the following add on:

Screenshot2

 

Select this add on and then choose: “Disable”

Once you do this, then close the add on window, then all your pdf’s will open in the browser window without getting acrobat blocked any more. 🙂

Hope this helps! Enjoy!