SharePoint 2013 Foundation install and .hta files on Server 2012

While doing some testing on a SharePoint 2013 Foundation install today I noticed that I had issues when installing it on a new Server 2012 VM in Hyper V. I got Windows Server 2012 and SQL 2012 (Database Engine only) installed just fine, but when I got ready to install the pre-requirements for 2013, I got an odd message that came up saying:

Which is odd because this used to just work in the 2010 version on Server 2008 R2. I suspect that the file handling works with 2013 just fine on the older Server OS as well, but in this case I am on Server 2012.

When selecting the ‘Open’ option you are asked what program you want to use to open this program. Huh?? Whaaa..??? Which then proceeds to give me the following error below:

From my experience so far, I have clicked on both yes and no in this case and everything just seems to hang there at the 2013 splash screen without doing anything. With my short attention span, I quickly close the program window and attempt to start again.

That is until I noticed what the above picture said about the URL before relating to a file being located at:

C:\Program Files(x86)\MSECache\SharePoint2010

So… I go hunting for this directory and find it, but in the back of my mind I am thinking, “This folder looks just like what the Disk or .ISO file looks like when SharePoint Server 2013 is mounted.”. So I click on the prereq installer and everything begins to install just fine.

Awesome! So after a couple of reboots everything seems to be configured just fine and the bits are ready to be installed.

I go merrily along through the screens I am used to until I see this screen pop up:

Booooo!!!! Microsoft!!!! They fixed this setting in SharePoint Server 2013, but why in the world would they not make the default setting for Foundation a complete install as well? People should not be doing stand-alone installs if they don’t know anything about SharePoint. This creates a whole host of issues when businesses start using SharePoint and then it begins to grow and grow and grow….then you hit the SQL 2008 R2 Express database size limitation and things go horribly wrong or just plain quit working. Long story short on this one, don’t do stand-alone installs. They make me a sad administrator.

One area to note is the second tab named ‘Data Location’. If you are installing SharePoint 2013 you need to configure this to drop your search index files in another drive or partition that you don’t mind filling up fast and growing very large. Just doing the default will install it on your root drive and when your searches begin to get large this can hurt performance if your search index files keep gobbling up all the storage your data or other important files need. Since this was a single box install, I didn’t have much choice, but make note of this for future setups.

After clicking ‘Install Now’ everything went as expected and completed with the familiar window that wants to run the configuration wizard after installing to complete the setup.

I will continue with more later, but I thought I would post this one for everyone that may just be getting into SharePoint 2013 Foundations like me since I couldn’t find anything online about it.

Thanks,

BJ

Advertisements

5 thoughts on “SharePoint 2013 Foundation install and .hta files on Server 2012”

  1. Microsoft is so dumb on some of thier very popular applications… sometimes, I wonder about thier QA process. Things just are never easy with thier products. You post saved me time.

  2. I have the sttupfile located on my harddrive. When asked which program to open .hta files with I choose “Windows Application Host” and the setup runs fine.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s